読者です 読者をやめる 読者になる 読者になる

でかるちゃー

毎日の発見に驚き、感じる!感謝する!

-スポンサードリンク-

Android Studio 2.1 で junit のエラー

最近、Android Studio さわってみています。

バージョンは、2.1です。

 

インストールPATHの修正とかで、何度かインストールし直していたら、

Failed to resolve: junit:junit:4.12 

 というエラーが出るようになった。

どうしてか、JUnitを上手く解釈してくれないらしい。

とりあえずググッて、Stack Overflow にはやたらと同じQAがあった。

ということで、build.gradle に 追記すれば良いらしい。

f:id:watouch:20160509194815p:plain

このファイルに、下のように太字部分を追記をすると解決するらしい。

apply plugin: 'com.android.application'

repositories {
maven { url 'http://repo1.maven.org/maven2' }

android {
compileSdkVersion 23
buildToolsVersion "23.0.3"
 :

 これで、プロジェクト単位ではこれで解決できるんだけど、そもそもこの Android Studio 全体の設定って出来ないものだろか?